Autor Thema: PCI-TV-Karten und neue Chipsätze (Haswell und Co.)  (Gelesen 1110 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline ritschibie

  • Aufpass-Cubie
  • *****
  • Beiträge: 8018
  • Ich liebe dieses Forum!
PCI-TV-Karten und neue Chipsätze (Haswell und Co.)
« am: 13 Oktober, 2013, 21:00 »
Jürgen hat es ja im Post zu dem Snoop Thread ("DVB-S2 Gerät für PC gesucht") schon erwähnt, aber vielleicht ist es gerade für uns, TV-Karten-Nutzer, ganz passend nochmals zu erwähnen, dass moderne (Intel-) Chipsätze eine ganz eigene PCI-Bus Anbindung besitzen. Sie binden diesen nicht mehr direkt an, sondern über einen "Bridge-Chip" an einen PCI-Express-Port des Chipsatzes, genannt "Platform Controller Hub (PCH)". Jetzt zitiere ich mal wörtlich aus der c't 22 (2013):

"Diese PCI-PCIe-Bridge kooperiert mit sehr vielen PCI-Karten, doch es klappt leider nicht immer reibungslos. So werden etwa manche PCI-Karten nicht erkannt oder beim Zugriff gibt es störende Latenzen. Diese können beispielsweise bei Sound- oder TV-Karten zu Aussetzern bei der Wiedergabe führen."

Ich hatte mir im Juli extra ein Haswell-Board mit PCI-Slots angeschafft wegen meiner TT 3200 S-2. Nach dem Einbau hatte ich nicht direkt Aussetzer, aber haufenweise "Bildstörungen". Ich hab das zunächst als isoliertes Problem meinerseits betrachtet und es nur öfter in der shout erwähnt (dachte nicht im geringsten an ein allgemeines Problem). Damals habe ich natürlich nach Problemen "Haswell" und TV-Karten gegooglet was das Zeug hielt, hatte aber nichts spezifisches gefunden. Nach einem Monat aller möglicher Eingriffe in Windows und Bios habe ich dann aufgegeben und mir die TechnoTrend TT-connect S2-3650 CI angeschafft. Die funktioniert einwandfrei, hat halt etwas längere Umschaltzeiten, sowohl der DVBViewer wie SmartDVB funzen haben kein Problem, den CI-Slot zu erkennen und zu nutzen.

So lernt man halt, das PCI nicht gleich (altem) PCI ist. Lehrgeld: knapp 100 €  ;D
Intel Core i7-4770K - ASRock Z87 Extreme6/ac - Crucial Ballistix Sport DIMM Kit 16GB, DDR3-1600 - Gigabyte Radeon R9 290 WindForce 3X OC
TBS DVB-S2 Dual Tuner TV Card Dual CI  - DVBViewer pro 5.3 und Smartdvb 4.x.x beta - 80 cm Schüssel, 2xQuad-LNB - Astra (19.2E)/Hotbird (13E)
I-net mit Motzfuchs ; WLAN: Fritz 7390; BS: Windows 10

Offline Dragonix

  • Premium-Cubie
  • ****
  • Beiträge: 293
Re: PCI-TV-Karten und neue Chipsätze (Haswell und Co.)
« Antwort #1 am: 13 Oktober, 2013, 23:02 »
x79 Bretter sind von dieser Problematik übrigens scheinbar nicht betroffen: Nur Mitglieder können Links sehen. Du kannst dich Registrieren oder Anmelden
Kann ich so auch bestätigen.

Offline ritschibie

  • Aufpass-Cubie
  • *****
  • Beiträge: 8018
  • Ich liebe dieses Forum!
Re: PCI-TV-Karten und neue Chipsätze (Haswell und Co.)
« Antwort #2 am: 14 Oktober, 2013, 10:47 »
Wenn ich den c't-Artikel richtig verstanden habe, dann sind auch nicht alle verbauten Chipsätze und Karten von diesen Störungen heimgesucht. Ich hab mich bei meiner damaligen Recherche im Netz auch auf Haswell (Z87) beschränkt. Trotzdem wäre ich (bin kein Techniker) wegen des im Z79 verbauten PCH nicht verwundert, wenn einige Karten bzw. Platinen bei Sound- oder TV-Karten "spinnen" würden. Umso mehr freue ich mich, dass es bei Dir so reibungslos klappt  ;)
Intel Core i7-4770K - ASRock Z87 Extreme6/ac - Crucial Ballistix Sport DIMM Kit 16GB, DDR3-1600 - Gigabyte Radeon R9 290 WindForce 3X OC
TBS DVB-S2 Dual Tuner TV Card Dual CI  - DVBViewer pro 5.3 und Smartdvb 4.x.x beta - 80 cm Schüssel, 2xQuad-LNB - Astra (19.2E)/Hotbird (13E)
I-net mit Motzfuchs ; WLAN: Fritz 7390; BS: Windows 10

Offline Jürgen

  • der Löter
  • Cheff-Cubie
  • *****
  • Beiträge: 4999
  • white LED trough prism - WTF is cyan?
Re: PCI-TV-Karten und neue Chipsätze (Haswell und Co.)
« Antwort #3 am: 15 Oktober, 2013, 01:57 »
Ich sehe aber auch ein grundsätzliches Problem beim Erkennen und (hoffentlich) Lösen solcher Probleme, und zwar primär in der immer geringeren Fallzahl.
Im gleichen Maße, wie PCI-e- und USB-Tuner am Markt die PCI-Tuner ablösen und PCI-Controller und -Soundkarten aussterben, vermindern sich die Anwendungen mit hoher PCI-Bus-Last und von PCI-Busmaster-Devices.
Umso länger dauert es und seltener tritt es auf, dass Chipsatz- und Mainboard-Hersteller entsprechendes Feedback erhalten und ggf. sogar noch Fixes anbieten könnten.

Insofern sollte man tatsächlich versuchen, auf eine (zeit)kritische Nutzung von Legacy-Schnittstellen zu verzichten.

Versuche mich gerade zu erinnern, wann ich zuletzt eine PCI-Karte eingesetzt habe, und heraus kommt dabei, dass das nicht die legendäre Nexus DVB-S war.
Selbige hatte ich aber zuletzt in einem Pentium 4 System verwendet, mit AGP und ohne PCI-e.
Kurz darauf hatte ich vorübergehend eine TT Skystar HD PCI im Einsatz, auf einem AM2-System mit 2x3GHz.
Die lieferte zwar sogar HD-Inhalte, aber aufgrund fehlender Hardware-Decoding-Unterstützung der damaligen Grafikkarten brauchte das Maschinchen weit über 200 Watt dafür, was für mich so nicht zu akzeptieren war.
Das gab den Ausschlag zur Anschaffung eines PVR-ready Receivers. Der schafft das für etwa 11 Watt (ggf. plus Stick oder Platte) deutlich besser...
 
Heute gibt es zwar billige Grafikkarten, die das auch ordentlich und recht sparsam können, geeignete Codecs vorausgesetzt.
Und selbst manche intel-Onboard-Grafik seit Core2 Duo bringt ordentliche Ergebnisse für ziemlich wenig Strom.
Dennoch bevorzuge ich für die tägliche Nutzung nach wie vor eindeutig meine Receiver, u.a. weil der PC dann aus bleiben oder völlig hemmungslos anders genutzt werden kann.
Frühere spezielle Motive für die Nutzung am PC sind ja auch seit längerer Zeit kaum noch gegeben.
Schnitt und Archivierung geschehen dann immer noch am PC, gelegentlich auch noch die Wiedergabe. 

Die multimediale Verbindung zwischen A/V- und PC-System besteht hier insofern hauptsächlich aus der 4:2 HDMI-Matrix, der externen Platte im Noxon-740 Mediaplayer (auch per USB oder LAN verfügbar) und ein paar USB-Sticks.
Nach Bedarf von allem auf alles...

Zwar habe ich nach wie vor meine USB-Tuner am PC, nutze die aber nur noch sehr unregelmäßig. Meist dient das nur Vergleichszwecken und technischen Tests.
Selbst USB 2.0 ist auf modernen Boards weitaus schnell genug für HD (h.264), solange man keine langsamen Devices gleichzeitig am selben Hub / Buchsenpaar betreibt.
Heutige Onboard-USB-Controller hängen ja stets entweder an PCI-e lanes oder per Hyper-Transport direkt am sehr schnellen zentralen Bus.

Jürgen
Kein Support per persönlicher Mitteilung!
Fragen gehören in's Forum.

Veränderungen stehen an. Dies ist der bisherige Stand:
28,x°,23.5°,19,2°,13°Ost
,1mØ Multifeed, mit Quattro LNBs; Multiswitches 4x 5/10(+x) - alle ohne Terrestrik und modifiziert für nur ein 12V DC Steckernetzteil (Verbrauch insgesamt 15 Watt)
1mØ mit DiSEqC 1.3/USALS als LNB2 an DVB-S2 STB, aktuell 30°W bis 55°O
1.) FM2A88X Extreme6+, A8-6600K (APU mit 4x 3,9 GHz und Radeon HD8570D), 16GB DDR3 1866, 128GB SSD, 3TB HDD, Win10 x64 Pro 1909 / 10.0.17763.107, Terratec T-Stick Plus (für DAB+), Idle Verbrauch ca. 35 Watt
2.) FM2A75 Pro 4, A8-5600K (APU mit 4x 3,6 GHz und Radeon HD7530D), 8GB DDR3 1600, 128GB SSD, 2TB HDD, Win10 x64 Pro, Idle Verbrauch ca. 45 Watt
3.) Raspberry Pi 512MB u.a. mit Raspbian
4.) GA-MA770-UD3, Phenom II x4 940, 8GB DDR2, Radeon HD6570, 2TiB, USB 3.0, 10 Pro x64 (+ XP Pro 32bit (nur noch offline)), Ubuntu 10.4 64bit, Cinergy S2 USB HD, NOXON DAB+ Stick, MovieBox Plus USB, ...

Samsung LE32B530 + Benq G2412HD @ HDMI 4:2; Tokaï LTL-2202B
XORO HRS-9200 CI+ (DVB-S2); XORO HRT-8720 (DVB-T2 HD)
Empfänger nur für FTA genutzt / ohne Abos
YAMAHA RX-V663 (AV-Receiver); marantz 7MKII; Philips SHP2700 ...
FritzBox 7590 mit VDSL2 50000

Offline Joutungwu

  • Mega-Cubie
  • ****
  • Beiträge: 176
Re: PCI-TV-Karten und neue Chipsätze (Haswell und Co.)
« Antwort #4 am: 18 August, 2016, 20:15 »
Das Problem erschien mir auch letztens, als ich meine alte Nova-S PCI in ein Asus P5K deluxe Board mit Intel E8400 Core 2 Duo reingesteckt und anchließend Windows 10 installiert habe. Demnach betrifft dieses Problem nicht nur die neuesten Chipsätze. Wenn eine alte PCI Schnittstelle keinen eigenen Controller hat, sondern über den PCI Express Controller mit betrieben wird, kann es wohl zu diesem Problem kommen. Ich habe das Problem bei mir durch viel Rumprobieren in den Griff bekommen und im Mediaportal Forum bereits darüber geschrieben. Jemand anderes hatte dort nämlich das gleiche Problem mit einer TT-Budget S-1600 auf einem Skylake System und die auftretenden Symptome gut beschrieben: Nur Mitglieder können Links sehen. Du kannst dich Registrieren oder Anmelden

Meine Vorgehensweise in Kurzform: Habe in den BIOS Einstellungen des Boards an den PCIE Frequenzeinstellungen rumgespielt, was jedoch zunächst nichts gebracht hat. Darauf habe ich alles wieder auf [Auto] gesetzt und plötzlich hat es dauerhaft funktioniert. Ist mir absolut unerklärlich, aber so ist es nunmal. umpf

Vorher habe ich noch herausgefunden, dass dieses Problem nur Windows 10 64 Bit betraf. Unter Kanotix (Live Modus) (gleiche IRQ-Belegung wie bei Windows) traten die Fehler nicht auf. Nach dem Neustart unter Windows dann erstmal auch nicht mehr. Blieb der Rechner längere Zeit aus (S5), oder wurde ein Netzteil Reset durchgeführt, kamen die Fehler unter Windows wieder zum Vorschein.  ::)
Nach der BIOS Spielerei blieb es jedoch dauerhaft fehlerfrei, auch nach dem Win10 Anniversary Update.   :)
« Letzte Änderung: 02 April, 2017, 15:45 von Joutungwu »
PC: Intel® Core™ i5-6500, ASRock H170 Pro4S, 16 GB DDR4-RAM, Samsung 850 EVO SATA III 2,5 Zoll 250 GB SSD, KFA2 GEFORCE GTX 960 GAMER OC 4GB, DVBSky S950, Windows 10 Prof. x64
Gäste-PC: Intel® Core™2 Duo Processor E8400, Asus P5K Deluxe/WiFi-AP, 4 GB DDR2-RAM, 250 GB HDD, Sparkle GeForce® GT 430, Hauppauge Nova-S PCI mit TT-Budget BDA-Treiber 5.0.3.6, Windows 10 Prof. x64
Sat.-Technik: Technisat GigaSystem 17/8 G, 4x Quattro-LNBs: 19.2° E, 13.0° E, 28.2° E, 7.0° E
DVB-Software: Mediaportal, SmartDVB

Offline Joutungwu

  • Mega-Cubie
  • ****
  • Beiträge: 176
Re: PCI-TV-Karten und neue Chipsätze (Haswell und Co.)
« Antwort #5 am: 24 Dezember, 2016, 15:53 »
Hallo,
hier nun auch nochmal zur Vollständigkeit:

Das Problem trat bei dem Rechner mit Asus P5K deluxe Board letztens nochmal auf, nachdem er einige Zeit komplett vom Stromnetz getrennt war. Darauf habe ich die 9.x Version der Intel Chipsatztreiber installiert. Ich hatte vorher eine 10.x drauf, genauer meine ich 10.0.0.27 (Die Installation der neueren 10.1.x.x bricht auf diesem Board/Chipsatz mit Fehlermeldung ab). Das 9er Chipset Utility hat die 10er Version erkannt und mich gefragt, ob ich die 9er trotzdem installieren möchte. Nach Installation der letzten Version 9.2.0.1030 und anschließendem Neustart war das Problem wieder behoben. Diese Beobachtung passt zu der Tatsache, dass es mit Linux keine Probleme gab. Allgemein heisst es oft, dass es ziemlich egal sei, welche Chipsatztreiber installiert sind, so dass ich mir darüber keine Gedanken gemacht habe. Anscheinend ist die 9er Version mit den älteren Chipsätzen (hier: P35) unter Windows 10 kompatibler.

Fazit: Falls das Problem auftritt, könnte der installierte Chipsatztreiber Schuld sein. Hat man nach frischer Windows Installation (hier: Windows 10) die MS-Treiber drauf, dann Intel Chipsatztreiber installieren und Rechner neu starten. Für die 6, 5, 4, 3, 900er Serie die 9er Version probieren, die neueren Chipsätze (Serien 7, 8, 9) brauchen wohl die 10er Version.

Übersicht der Intel-Chipsätze auf Wikipedia: Nur Mitglieder können Links sehen. Du kannst dich Registrieren oder Anmelden

EDIT: Die Installation der Chipsatztreiber, hat nur für ein paar Tage gewirkt, danach trat das Problem wieder auf. Neues (vorläufiges) Fazit: Bei diesem Board hilft nur der oben beschriebene BIOS Trick dauerhaft und zwar so lange bis das Netzteil für eine unbestimmte Zeit vom Strom getrennt wird. Wird der Rechner heruntergefahren in den S5 und das Netzteil bleibt am Strom angeschlossen, kann er auch nach Monaten wieder hochgefahren werden und das Bild ist fehlerfrei.

Grüße
Joutungwu
« Letzte Änderung: 02 April, 2017, 15:42 von Joutungwu »
PC: Intel® Core™ i5-6500, ASRock H170 Pro4S, 16 GB DDR4-RAM, Samsung 850 EVO SATA III 2,5 Zoll 250 GB SSD, KFA2 GEFORCE GTX 960 GAMER OC 4GB, DVBSky S950, Windows 10 Prof. x64
Gäste-PC: Intel® Core™2 Duo Processor E8400, Asus P5K Deluxe/WiFi-AP, 4 GB DDR2-RAM, 250 GB HDD, Sparkle GeForce® GT 430, Hauppauge Nova-S PCI mit TT-Budget BDA-Treiber 5.0.3.6, Windows 10 Prof. x64
Sat.-Technik: Technisat GigaSystem 17/8 G, 4x Quattro-LNBs: 19.2° E, 13.0° E, 28.2° E, 7.0° E
DVB-Software: Mediaportal, SmartDVB